import Foundation
let pattern = #"(I like to find )(.*?)( in )([^.]*)(\.)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
I like to find something vicous in somewhere bla bla bla.
https://address.suffix.com/level/somelongurlstuff
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4 $2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}