using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}-\d{2}-\d{2} FIG \d+";
string input = @"20-40-55 FIG 20 text text 20-40-55 FIG 1000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}