$re = '/\d{2}-\d{2}-\d{2} FIG \d+/';
$str = '20-40-55 FIG 20 text text 20-40-55 FIG 1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);