const regex = /\d{2}-\d{2}-\d{2} FIG \d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}-\\d{2}-\\d{2} FIG \\d+', 'g')
const str = `20-40-55 FIG 20 text text 20-40-55 FIG 1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}