re = /\d{2}-\d{2}-\d{2} FIG \d+/
str = '20-40-55 FIG 20 text text 20-40-55 FIG 1000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end