using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]+\d+)[\u0020*\u0009]*;[\u0020*\u0009]*([A-Z]+\d+)$";
string input = @"A1 ; B203
AZ101; CZ1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}