package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]+\d+)[\u0020*\u0009]*;[\u0020*\u0009]*([A-Z]+\d+)$`)
var str = `A1 ; B203
AZ101; CZ1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}