const regex = /^([A-Z]+\d+)[\u0020*\u0009]*;[\u0020*\u0009]*([A-Z]+\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]+\\d+)[\\u0020*\\u0009]*;[\\u0020*\\u0009]*([A-Z]+\\d+)$', 'gm')
const str = `A1 ; B203
AZ101; CZ1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}