// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z]+\d+)[\u0020*\u0009]*;[\u0020*\u0009]*([A-Z]+\d+)$").unwrap();
let string = "A1 ; B203
AZ101; CZ1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}