package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((est)\s[0-9]?[0-9]?(ème))\s?(de)?\s?(L1)?`)
var str = `Bordeaux est 8ème de L1. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}