re = /((est)\s[0-9]?[0-9]?(ème))\s?(de)?\s?(L1)?/m
str = 'Bordeaux est 8ème de L1. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end