use strict;
my $str = 'my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this';
my $regex = qr/MY_START_WORD_KEY\s.*?\sMY_END_WORD_KEY/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}