import re
regex = re.compile(r'MY_START_WORD_KEY\s.*?\sMY_END_WORD_KEY', flags=re.MULTILINE)
test_str = "my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")