re = /MY_START_WORD_KEY\s.*?\sMY_END_WORD_KEY/m
str = 'my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end