// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)MY_START_WORD_KEY\s.*?\sMY_END_WORD_KEY").unwrap();
let string = "my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this MY_START_WORD_KEY my text this my text this my text this my text this my text this MY_END_WORD_KEY my random text this my random text this my random text this my random text this my random text this";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}