import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "9([\\s]*)(\\d[\\s]*){9}";
final String string = "HELLO9 40 0001 103 940 060 1148 96 20 01 47 14 940 00A011 27 9 620014 724 9 320009350 9 62 0005 368WORLD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}