use strict;
my $str = 'HELLO9 40 0001 103 940 060 1148 96 20 01 47 14 940 00A011 27 9 620014 724 9 320009350 9 62 0005 368WORLD';
my $regex = qr/9([\s]*)(\d[\s]*){9}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}