re = /9([\s]*)(\d[\s]*){9}/m
str = 'HELLO9 40 0001 103 940 060 1148 96 20 01 47 14 940 00A011 27 9 620014 724 9 320009350 9 62 0005 368WORLD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end