// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)9([\s]*)(\d[\s]*){9}").unwrap();
let string = "HELLO9 40 0001 103 940 060 1148 96 20 01 47 14 940 00A011 27 9 620014 724 9 320009350 9 62 0005 368WORLD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}