using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:YV[^\W_]{8}|S?VNA[^\W_]{5})\b";
string input = @"There are four serial numbers in here: ;YV12345678. VNA1234A and ,VNAB4321 or :SVNA12345 here and a couple that won't be of interest YV123456789 VNA123456 or SVNA1234
2020-03-24 15:47:46 - (Work notes) Monitor, wired keyboard/mouse SVNA3L3A0 picked up equipment 2020-03-16 08:51:04 - (Work notes) Hello, I see that the monitor part of your ticket is incomplete. Update me with this information.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}