const regex = /\b(?:YV[^\W_]{8}|S?VNA[^\W_]{5})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:YV[^\\W_]{8}|S?VNA[^\\W_]{5})\\b', 'gm')
const str = `There are four serial numbers in here: ;YV12345678. VNA1234A and ,VNAB4321 or :SVNA12345 here and a couple that won't be of interest YV123456789 VNA123456 or SVNA1234
2020-03-24 15:47:46 - (Work notes) Monitor, wired keyboard/mouse SVNA3L3A0 picked up equipment 2020-03-16 08:51:04 - (Work notes) Hello, I see that the monitor part of your ticket is incomplete. Update me with this information.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}