package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:YV[^\W_]{8}|S?VNA[^\W_]{5})\b`)
var str = `There are four serial numbers in here: ;YV12345678. VNA1234A and ,VNAB4321 or :SVNA12345 here and a couple that won't be of interest YV123456789 VNA123456 or SVNA1234
2020-03-24 15:47:46 - (Work notes) Monitor, wired keyboard/mouse SVNA3L3A0 picked up equipment 2020-03-16 08:51:04 - (Work notes) Hello, I see that the monitor part of your ticket is incomplete. Update me with this information.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}