// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:YV[^\W_]{8}|S?VNA[^\W_]{5})\b").unwrap();
let string = "There are four serial numbers in here: ;YV12345678. VNA1234A and ,VNAB4321 or :SVNA12345 here and a couple that won't be of interest YV123456789 VNA123456 or SVNA1234
2020-03-24 15:47:46 - (Work notes) Monitor, wired keyboard/mouse SVNA3L3A0 picked up equipment 2020-03-16 08:51:04 - (Work notes) Hello, I see that the monitor part of your ticket is incomplete. Update me with this information.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}