using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0,(?!0,)[^,]+,1,0$";
string input = @"1,0,0,0
0,100,0,0
0,0,1,0
0,0,0,100
1,100,0,0
1,0,1,0
1,0,0,100
0,100,1,0
0,100,0,100
0,0,1,100
1,100,1,0
1,100,0,100
1,0,1,100
0,100,1,100
1,100,1,100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}