$re = '/^0,(?!0,)[^,]+,1,0$/m';
$str = '1,0,0,0
0,100,0,0
0,0,1,0
0,0,0,100
1,100,0,0
1,0,1,0
1,0,0,100
0,100,1,0
0,100,0,100
0,0,1,100
1,100,1,0
1,100,0,100
1,0,1,100
0,100,1,100
1,100,1,100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);