import re
regex = re.compile(r"^0,(?!0,)[^,]+,1,0$", flags=re.MULTILINE)
test_str = ("1,0,0,0\n"
"0,100,0,0\n"
"0,0,1,0\n"
"0,0,0,100\n"
"1,100,0,0 \n"
"1,0,1,0\n"
"1,0,0,100\n"
"0,100,1,0\n"
"0,100,0,100\n"
"0,0,1,100\n"
"1,100,1,0\n"
"1,100,0,100\n"
"1,0,1,100\n"
"0,100,1,100\n"
"1,100,1,100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")