import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0,(?!0,)[^,]+,1,0$";
final String string = "1,0,0,0\n"
+ "0,100,0,0\n"
+ "0,0,1,0\n"
+ "0,0,0,100\n"
+ "1,100,0,0 \n"
+ "1,0,1,0\n"
+ "1,0,0,100\n"
+ "0,100,1,0\n"
+ "0,100,0,100\n"
+ "0,0,1,100\n"
+ "1,100,1,0\n"
+ "1,100,0,100\n"
+ "1,0,1,100\n"
+ "0,100,1,100\n"
+ "1,100,1,100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}