package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-(front|back)`)
var str = `image 123-front
image 123-back
image XYZ-front
image XYZ-back`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}