$re = '/-(front|back)/';
$str = 'image 123-front
image 123-back
image XYZ-front
image XYZ-back';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);