re = /-(front|back)/
str = 'image 123-front
image 123-back
image XYZ-front
image XYZ-back'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end