const regex = /-(front|back)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-(front|back)', 'g')
const str = `image 123-front
image 123-back
image XYZ-front
image XYZ-back`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}