import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d\\.\\d*\\*?)([\\*\\.,])";
final String string = " 1 ****TABLE1****\n"
+ " COLUMN1= 1.12, 2.23, 3.34, 4.45, 5.56, 6.67, \n"
+ " COLUMN2= 0.00, 0.00, 0.00, 0.00, 0.00, 0.00,\n"
+ " COLUMN3= 1.23, 0.34, 3.45, 5.78*, 6.54*, 8.23.,\n"
+ " 1 ****TABLE2****";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}