import re
regex = re.compile(r"(?<=\d\.\d*\*?)([\*\.,])", flags=re.MULTILINE)
test_str = (" 1 ****TABLE1****\n"
" COLUMN1= 1.12, 2.23, 3.34, 4.45, 5.56, 6.67, \n"
" COLUMN2= 0.00, 0.00, 0.00, 0.00, 0.00, 0.00,\n"
" COLUMN3= 1.23, 0.34, 3.45, 5.78*, 6.54*, 8.23.,\n"
" 1 ****TABLE2****")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")