re = /(?<=\d\.\d*\*?)([\*\.,])/m
str = ' 1 ****TABLE1****
COLUMN1= 1.12, 2.23, 3.34, 4.45, 5.56, 6.67,
COLUMN2= 0.00, 0.00, 0.00, 0.00, 0.00, 0.00,
COLUMN3= 1.23, 0.34, 3.45, 5.78*, 6.54*, 8.23.,
1 ****TABLE2****'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end