using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*Number:\s*|^)(\S+)";
string input = @"ABC123 bla bla
Number: ABC123 bla bla
Some words 123 Number: ABC123 bla bla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}