$re = '/(?:.*Number:\s*|^)(\S+)/m';
$str = 'ABC123 bla bla
Number: ABC123 bla bla
Some words 123 Number: ABC123 bla bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);