package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*Number:\s*|^)(\S+)`)
var str = `ABC123 bla bla
Number: ABC123 bla bla
Some words 123 Number: ABC123 bla bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}