re = /(?:.*Number:\s*|^)(\S+)/m
str = 'ABC123 bla bla
Number: ABC123 bla bla
Some words 123 Number: ABC123 bla bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end