using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/id=[0-9]+$";
string input = @"https://domain.com/id=13234
https://domain.com/id=23443-wrong-part
https://domain.com/id=wrong-non-number-id";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}