$re = '/\/id=[0-9]+$/m';
$str = 'https://domain.com/id=13234
https://domain.com/id=23443-wrong-part
https://domain.com/id=wrong-non-number-id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);