re = /\/id=[0-9]+$/m
str = 'https://domain.com/id=13234
https://domain.com/id=23443-wrong-part
https://domain.com/id=wrong-non-number-id'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end