using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.(\d+).\|(.*?)\|(.*?)\|(.*?)\|(.*?)\|(.*)";
string input = @"# 2017-07-19T09:06:44.115456Z|i|6868|11048|pfup|login: Login failed -- primary authentication for abes667 failed
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}