package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.(\d+).\|(.*?)\|(.*?)\|(.*?)\|(.*?)\|(.*)`)
var str = `# 2017-07-19T09:06:44.115456Z|i|6868|11048|pfup|login: Login failed -- primary authentication for abes667 failed
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}