re = /(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.(\d+).\|(.*?)\|(.*?)\|(.*?)\|(.*?)\|(.*)/
str = '# 2017-07-19T09:06:44.115456Z|i|6868|11048|pfup|login: Login failed -- primary authentication for abes667 failed
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end