const regex = /^(\d{3})(\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{3})(\\d{4})', 'gm')
const str = `123456789`;
const subst = `$1-$2-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);