import re
regex = re.compile(r"^(\d{3})(\d{4})", flags=re.MULTILINE)
test_str = "123456789"
subst = "$1-$2-"
result = regex.sub(subst, test_str)
if result:
print(result)