$re = '/^(\d{3})(\d{4})/m';
$str = '123456789';
$subst = "$1-$2-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;