import Foundation
let pattern = #"^(\d{3})(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"123456789"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)