use strict;
my $str = '# CHART: Share of persons living at risk of poverty or social exclusion ====
df <- S3R0004_M3080242 %>%
mutate(LAIKOTARPIS=parse_date_time(LAIKOTARPIS, "y"))
jpeg("./figures/Share of persons living at risk of poverty or social exclusion.jpeg", width = 9, height = 6, units = \'in\', res = 600)
ggplot(data = df, aes(x=LAIKOTARPIS, y=obsValue)+';
my $regex = qr/(?:\G(?!\A)|jpeg\("(?=[^"]*"[^)]*600\)))[^\s"]*\K\s+/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";