import re
regex = re.compile(r"(?:\G(?!\A)|jpeg\(\"(?=[^\"]*\"[^)]*600\)))[^\s\"]*\K\s+", flags=re.MULTILINE)
test_str = ("# CHART: Share of persons living at risk of poverty or social exclusion ====\n"
"df <- S3R0004_M3080242 %>% \n"
" mutate(LAIKOTARPIS=parse_date_time(LAIKOTARPIS, \"y\")) \n"
"jpeg(\"./figures/Share of persons living at risk of poverty or social exclusion.jpeg\", width = 9, height = 6, units = 'in', res = 600)\n"
"ggplot(data = df, aes(x=LAIKOTARPIS, y=obsValue)+")
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)